Developer Support Iotic Labs

Python2 compatibility

 

If you would prefer to use Python2, you will need to make your script compatible by adding the lines below to the top of your .py file.

 

Python logo


# PYTHON2 COMPATIBILITY -----------------------------------------------------------------------------------------------
from __future__ import unicode_literals, print_function  # pylint: disable=unused-import

 

 

Remember, before you can hook your Thing up to code you also need to:

 

  1. Create a new Iotic Agent in the Space app, and download an .ini file
  2. Assign Things to an Agent
  3. Organise your file directory

By continuing to use the site, you agree to the use of cookies. more information

This website uses cookies via Google Analytics to give you the best browsing experience possible. No personally-identifiable information is collected about you unless you explicitly submit that information on this website. Click "Accept" to continue.

Close